Overpass API developpement

Text archives Help


Re: [overpass] Can't run some queries (they time out)


Chronological Thread 
  • From: FRANCHOIS Serge <serge.franchois@altran.com>
  • To: "overpass@listes.openstreetmap.fr" <overpass@listes.openstreetmap.fr>
  • Cc: "overpass@osm101.openstreetmap.fr" <overpass@osm101.openstreetmap.fr>
  • Subject: Re: [overpass] Can't run some queries (they time out)
  • Date: Thu, 10 Nov 2016 20:20:23 +0000
  • Accept-language: en-US

First time I pay attention to that. That is indeed strange.
Here’s how I built the database, as per instructions : 

$ nohup $EXEC_DIR/bin/init_osm3s.sh $PLANET_FILE $DB_DIR $EXEC_DIR --meta &

I’ve no access to my overpass VM at the moment. Will dig in the logs on Monday. 
Where are those timestamps coming from anyway?


Thanks for your support!
Serge




On 10 Nov 2016, at 18:30, mmd <mmd.osm@gmail.com> wrote:

Am 10.11.2016 um 11:18 schrieb FRANCHOIS Serge:

<meta osm_base="2012-12-07T16:05:03Z" areas="2012-12-07T16:05:03Z"/>

Hmm, out of curiosity, why is your database almost 4 years old?



</osm>
runtime error: Query failed with the exception: Zlib_Inflate: -3

Above is the error I get now. Is this a bug, or expected behaviour?

No. Possibly something went wrong when loading your database. Can you
provide more details on how you set up your DB in the first place, any
error messages in your log files, etc.? Do you get the same error with a
clone database as well?


Btw, is there a stable version that we can use, instead of the latest development version?

If you use https://urldefense.proofpoint.com/v2/url?u=http-3A__dev.overpass-2Dapi.de_releases_osm-2D3s-5Fv0.7.53.tar.gz&d=DgID-g&c=cxWN2QSDopt5SklNfbjIjg&r=oyE2E43r812vhUo6Hy33TngT4G8-n9bD2MuRIiPL-BU&m=HMHhpa15xojlYDCCCij0sLdg1NP32f8pJrwpaoPPPeM&s=QZqL2QzJ7e8905cR8fBG6kjYuFakHT2FGBGJuOdSkm4&e= ,
that's the currently released version that is also running on
overpass-api.de.


--






Archive powered by MHonArc 2.6.18.

Top of page